Westpac Service Disruption
Incident Report for BlinkPay
Resolved
Service has been restored. See https://status.westpac.co.nz for more information.
Posted Feb 12, 2025 - 21:01 NZDT
Identified
Please see https://status.westpac.co.nz for more information on the incident.
Posted Feb 11, 2025 - 23:00 NZDT
This incident affected: Westpac.